Methodox Formula 响应下列按键。前面几个表是带有快捷键的菜单命令(从窗口本身生成)以及窗口绑定的其他按键;后面几个表是网格、正在编辑的单元格和工作表标签的按键。每个菜单都会在菜单项旁边显示其快捷键,将鼠标悬停在工具栏按钮上会显示其名称。按 F10,或按 Alt 加菜单的带下划线字母,可以用键盘打开菜单。
菜单命令
File 菜单
| 按键 |
命令 |
Ctrl+N |
File ▸ New |
Ctrl+O |
File ▸ Open… |
Ctrl+S |
File ▸ Save |
Ctrl+Shift+S |
File ▸ Save As… |
Ctrl+P |
File ▸ Print… |
Ctrl+W |
File ▸ Close |
Ctrl+Q |
File ▸ Exit |
Edit 菜单
| 按键 |
命令 |
Ctrl+Z |
Edit ▸ Undo |
Ctrl+Y |
Edit ▸ Redo |
Ctrl+Shift+Y |
Edit ▸ Repeat |
Ctrl+X |
Edit ▸ Cut |
Ctrl+C |
Edit ▸ Copy |
Ctrl+V |
Edit ▸ Paste |
Ctrl+Shift+V |
Edit ▸ Paste Special ▸ Paste Special… |
Ctrl+Alt+Shift+V |
Edit ▸ Paste Special ▸ Unformatted Text |
Ctrl+F |
Edit ▸ Find… |
Ctrl+H |
Edit ▸ Find and Replace… |
F3 |
Edit ▸ Find Next |
Shift+F3 |
Edit ▸ Find Previous |
Ctrl+A |
Edit ▸ Select All |
F5 |
Edit ▸ Go To… |
Ctrl+; |
Edit ▸ Insert Current Date |
Ctrl+Shift+; |
Edit ▸ Insert Current Time |
Backspace |
Edit ▸ Delete Contents… |
View 菜单
| 按键 |
命令 |
Ctrl+Shift+U |
View ▸ Expand Formula Bar |
| `Ctrl+`` |
View ▸ Show Formula |
Ctrl+Shift+J |
View ▸ Full Screen |
Insert 菜单
| 按键 |
命令 |
Ctrl+T |
Insert ▸ Table… |
Ctrl+F2 |
Insert ▸ Function… |
Ctrl+Alt+C |
Insert ▸ Comment… |
Ctrl+K |
Insert ▸ Hyperlink… |
Sheet 菜单
| 按键 |
命令 |
Ctrl+Keypad + |
Sheet ▸ Insert Cells… |
Ctrl+Keypad - |
Sheet ▸ Delete Cells… |
Ctrl+D |
Sheet ▸ Fill Down |
Ctrl+R |
Sheet ▸ Fill Right |
Data 菜单
| 按键 |
命令 |
Ctrl+Shift+L |
Data ▸ AutoFilter |
Ctrl+Shift+Q |
Data ▸ SQL Workbench |
Alt+F5 |
Data ▸ PivotTable ▸ Refresh |
Ctrl+Alt+F5 |
Data ▸ PivotTable ▸ Refresh All |
F9 |
Data ▸ Calculate ▸ Recalculate |
Ctrl+Shift+F5 |
Data ▸ Refresh Data |
| 按键 |
命令 |
Ctrl+B |
Format ▸ Bold |
Ctrl+I |
Format ▸ Italic |
Ctrl+U |
Format ▸ Underline |
Ctrl+Shift+P |
Format ▸ Text ▸ Superscript |
Ctrl+Shift+B |
Format ▸ Text ▸ Subscript |
Ctrl+] |
Format ▸ Text ▸ Increase Font Size |
Ctrl+[ |
Format ▸ Text ▸ Decrease Font Size |
| `Ctrl+Shift+`` |
Format ▸ Number Format ▸ General |
Ctrl+Shift+1 |
Format ▸ Number Format ▸ Number |
Ctrl+Shift+4 |
Format ▸ Number Format ▸ Currency |
Ctrl+Shift+5 |
Format ▸ Number Format ▸ Percent |
Ctrl+Shift+3 |
Format ▸ Number Format ▸ Date |
Ctrl+Shift+2 |
Format ▸ Number Format ▸ Time |
Ctrl+Shift+6 |
Format ▸ Number Format ▸ Scientific |
Ctrl+9 |
Format ▸ Rows ▸ Hide Rows |
Ctrl+Shift+9 |
Format ▸ Rows ▸ Show Rows |
Ctrl+0 |
Format ▸ Columns ▸ Hide Columns |
Ctrl+Shift+0 |
Format ▸ Columns ▸ Show Columns |
Ctrl+1 |
Format ▸ Cells… |
| 按键 |
命令 |
F7 |
Tools ▸ Spelling… |
Shift+F7 |
Tools ▸ Automatic Spell Checking |
Shift+F9 |
Tools ▸ Detective ▸ Trace Precedents |
Shift+F5 |
Tools ▸ Detective ▸ Trace Dependents |
Alt+F11 |
Tools ▸ Scripts |
Document 菜单
| 按键 |
命令 |
Ctrl+F6 |
Document ▸ Next Document |
Ctrl+Shift+F6 |
Document ▸ Previous Document |
Help 菜单
| 按键 |
命令 |
F1 |
Help ▸ Documentation |
其他按键
| 按键 |
命令 |
Ctrl+G |
Edit ▸ Go To…(第二个快捷键) |
Ctrl+L |
Insert ▸ Table…(第二个快捷键) |
Alt+= |
Data ▸ AutoSum |
F4 |
对所选内容重复上一个操作 |
Shift+F2 |
Insert ▸ Comment…(第二个快捷键) |
Ctrl+Shift+7 |
为所选内容添加外边框 |
Ctrl+Shift+- |
删除所选内容的边框 |
Ctrl+- |
Sheet ▸ Delete Cells… |
Ctrl+Shift+= |
Sheet ▸ Insert Cells… |
Shift+F11 |
插入工作表 |
Ctrl+' |
复制上方单元格的公式 |
Ctrl+Shift+' |
复制上方单元格的值 |
Ctrl+Shift+O |
选择带有批注的单元格 |
Ctrl+PgDn |
下一个工作表 |
Ctrl+PgUp |
上一个工作表 |
Ctrl+Tab |
下一个打开的文档(文档拥有键盘焦点时) |
Ctrl+Shift+Tab |
上一个打开的文档(文档拥有键盘焦点时) |
在网格中移动和选择
| 按键 |
作用 |
← → ↑ ↓ |
移动活动单元格 |
Ctrl+← Ctrl+→ Ctrl+↑ Ctrl+↓ |
跳到数据块的边缘 |
Shift 加任意移动键 |
扩展选择范围 |
Enter Shift+Enter |
向下或向上移动(或按 Edit ▸ Options ▸ Formula 中的设置);在选择范围内时,移到其中的下一个或上一个单元格 |
Tab Shift+Tab |
向右或向左移动;在选择范围内时,移到其中的下一个或上一个单元格 |
Page Up Page Down |
向上或向下翻一屏 |
Home |
当前行的 A 列 |
Ctrl+Home |
单元格 A1 |
End |
当前行最后一个已使用的列 |
Ctrl+End |
已使用区域的末尾 |
Ctrl+Space |
选择整列 |
Shift+Space |
选择整行 |
F2 |
编辑活动单元格,方向键用于移动插入点 |
| 任意字符 |
开始在活动单元格中输入以覆盖其内容,方向键用于确认并移动 |
Delete |
清除所选内容 |
Alt+↓ |
打开单元格的数据验证列表 |
选中图表、图片或形状时按 Delete Backspace |
删除该对象 |
选中对象时按 Esc |
取消选择该对象;格式刷处于启用状态时,取消格式刷 |
编辑单元格
| 按键 |
作用 |
Enter |
确认并向下移动(或按 Edit ▸ Options ▸ Formula 中的设置);在连续按 Tab 之后,回到开始按 Tab 时所在的列 |
Shift+Enter |
确认并向上移动 |
Tab Shift+Tab |
确认并向右或向左移动 |
← → ↑ ↓ |
在通过直接输入打开的单元格中,确认并移动;在通过 F2 或双击打开的单元格中,移动插入点 |
F2 |
在上述两种方式之间切换;在公式中,在指向单元格和移动插入点之间切换 |
Alt+Enter Ctrl+Enter |
选中一个区域时,将输入内容填入每个单元格;在单个单元格中,插入单元格内换行 |
Esc |
取消编辑 |
F4 |
在 $A$1、A$1、$A1 和 A1 之间循环切换插入点处的引用 |
输入公式时按 ← → ↑ ↓ |
在可以放置引用的位置指向一个单元格;按住 Shift 时指向一个区域 |
在自动完成建议上按 Enter |
采用该建议 |
Ctrl+Backspace Ctrl+Delete |
删除一个单词 |
Ctrl+Z Ctrl+Y |
在单元格内撤消或恢复 |
在编辑栏中,Enter 确认、Esc 取消,F4 以同样的方式循环切换引用。在 Name Box 中,Enter 会跳转到输入的名称或引用,或为所选内容定义一个新名称。
工作表标签
| 按键 |
作用 |
← → |
上一个或下一个工作表(工作表标签拥有键盘焦点时) |
F2 |
重命名工作表 |
鼠标
| 手势 |
作用 |
Ctrl + 滚轮 |
缩放 |
Shift + 滚轮 |
横向滚动 |
Shift + 单击 |
扩展选择范围 |
Ctrl + 单击 |
向选择范围中再添加一个区域;在超链接上时,打开该链接 |
| 双击单元格 |
编辑该单元格 |
| 双击列或行的边框 |
使其适应内容 |
| 拖动填充柄 |
填充序列;按住 Ctrl 时改为复制 |
| 双击填充柄 |
向下填充,直到旁边一列的末尾 |
| 拖动表的角手柄 |
扩大或缩小表 |
| 单击格式刷,双击格式刷 |
对下一次选择应用一次格式;持续应用格式,直到按 Esc |
Ctrl 或 Shift + 单击工作表标签 |
选择多个工作表 |
在 SQL Workbench 中,Ctrl+Enter 或 F5 运行语句。
尚未支持:Ctrl+Page Up 和 Ctrl+Page Down 不能切换工作表,Ctrl+Shift+Enter 不能输入数组公式(溢出公式不需要它)。
在 Scripts 选项卡中
Tools ▸ Scripts(Alt+F11)会在底部托盘中打开脚本编辑器。当编辑器拥有键盘焦点时,它自己的按键优先于窗口的按键:Ctrl+F 搜索的是脚本而不是文档。
| 按键 |
作用 |
Ctrl+Enter |
运行脚本 |
Ctrl+Shift+Enter |
运行选中的行 |
Ctrl+N |
新建脚本 |
Ctrl+Space |
显示补全;输入 .(在 Lua 中为 :)也会显示补全 |
Enter Tab |
接受补全;Esc 关闭列表 |
Tab Shift+Tab |
增加或减少当前行或选中各行的缩进 |
Ctrl+/ |
注释或取消注释选中的行 |
Ctrl+G |
转到某一行 |
Ctrl+D |
删除当前行 |
Insert |
开启或关闭改写模式 |
Ctrl+Backspace Ctrl+Delete |
删除插入点之前或之后的单词 |
Alt+Shift+← Alt+Shift+→ Alt+Shift+↑ Alt+Shift+↓ |
矩形选择 |
Ctrl+F |
在脚本中查找 |
Ctrl+H |
在脚本中查找和替换 |
F3 Shift+F3 |
下一个或上一个匹配项 |
Alt+R Alt+A |
在查找栏打开时,替换或全部替换 |
Ctrl+Tab |
离开编辑器 |
在脚本列表中:
| 按键 |
作用 |
Insert Ctrl+N |
新建脚本 |
F2 |
重命名脚本 |
Ctrl+D |
复制脚本 |
Delete |
询问后删除脚本 |
在 Immediate 选项卡中:
| 按键 |
作用 |
Enter |
运行该行并打印其值 |
Shift+Enter |
另起一行;在 Python 中,以冒号结尾的行也会另起一行 |
Ctrl+Enter |
运行已输入的各行 |
↑ ↓ |
逐条浏览之前运行过的内容 |
在图编辑器中:
| 按键或手势 |
作用 |
| 在画布空白处右键单击 |
从可搜索的面板中添加节点 |
| 右键单击节点、连线或图的选项卡 |
打开其菜单 |
按住中键拖动,或按住 Alt 或 Space 拖动 |
平移 |
| 滚轮 |
以指针为中心缩放 |
F |
使图适应视图 |
Ctrl+X Ctrl+C Ctrl+V |
剪切、复制和粘贴节点及其之间的连线 |
Ctrl+D |
复制选中的节点 |
Delete |
删除选中的节点 |
Alt+单击连线 |
断开该连线 |
Ctrl+Z Ctrl+Y |
撤消和恢复画布上的操作 |
另请参阅